Jump to content


Photo
- - - - -

Fabia 1.4 8v MPI camshaft position sensor?


  • Please log in to reply
9 replies to this topic

#1 Phil_Fabia

Phil_Fabia

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 12 June 2011 - 21:24

Hi all,

I have a problem with my 2001 Fabia 1.4 8v MPI. The engine check light has come on and the VAG fault code reader is giving a 16725 P0341 Camshaft Position Sensor Circuit - Out of Range/Performance. The car runs OK and starts reasonably well. I have cleaned the contacts on the camshaft sensor, etc, but as soon as the engine turns over the code reappears on the fault reader.

Does anyone have any experience with this? Is it likely to be the camshaft sensor needing replaced? (I know that seems obvious, but I have been in the situation where changing a spark plug fixes an injector fault code, etc).

The car had it's timing chain changed at 97K by previous owner, (which I know if it is done wrongly can cause this), but the engine check light didn't come on until a few months later. Could it still be this? How can I check this without giving it to a mechanic?

Any experience, suggestions or informed reckonings welcomed,

Phil

Edited by Phil_Fabia, 12 June 2011 - 21:24.


#2 Phil_Fabia

Phil_Fabia

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 14 June 2011 - 15:58

Bump, any opinions welcomed!!!!!!!

#3 MoggyTech

MoggyTech

    Briskodian

  • Members
  • PipPipPipPipPipPip
  • 5,874 posts
  • Location:West Lothian
  • Car:Fabia VRS LE / Morris 1000 Traveler

Posted 14 June 2011 - 17:22

Replace sensor and go from there.

#4 Tech1e

Tech1e

    Cruise Control Guru

  • Honorary
  • PipPipPipPipPipPipPipPip
  • 32,644 posts
  • Location:Worcs
  • Car:Fabia 1.4 MPI+ SEAT Leon TDI S

Posted 14 June 2011 - 17:44

Replace sensor and go from there.


Agreed

#5 anewman

anewman

    Briskodian

  • Members
  • PipPipPipPipPipPip
  • 6,526 posts

Posted 14 June 2011 - 21:58

I think you'd have problems with power if the chain was not installed correctly, and it would be noisy if the new chain had stretched. Plus I imagine the light would have come on almost immediately after replacement if it was that - in the same way it comes up immediately now. ISTR it is possible to view the values from the sensor in VCDS and Skoda specify a range, but that would probably just be academic.

#6 Phil_Fabia

Phil_Fabia

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 16 June 2011 - 09:18

Thanks guys, will look for a new sensor and post my results for future reference

#7 Phil_Fabia

Phil_Fabia

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 20 June 2011 - 21:19

hi guys,

I have been offered a camshaft position sensor for a Fabia mk1 1.4 16v for not too much money. will this work on my 1.4 8v??????? I am having real problems finding a second-hand CPS for the 8v.

Thanks Phil


#8 anewman

anewman

    Briskodian

  • Members
  • PipPipPipPipPipPip
  • 6,526 posts

Posted 20 June 2011 - 22:17

Apparently not, and also there are two different types depending on your chassis number.

Part number: 06A905377A

Knock sensor with wiring harness / F >> 6Y-1-286 342*
225MM brown


Part number: 06A905377C

knock sensor with wiring harness / F 6Y-1-286 343>>*
235MM brown

But I guess both are the same and one has a 10mm longer cable.

http://cgi.ebay.co.u...=item45f4bb279e

Does not mention part number but says that knock sensor fits a rather wide range of cars - you might be able to find one of those at a scrappy and give it a shot.

Edit: balls that's the knock sensor, entirely different to CPS.

#9 anewman

anewman

    Briskodian

  • Members
  • PipPipPipPipPipPip
  • 6,526 posts

Posted 25 June 2011 - 23:14

Balls I really can't see how I mistook a knock sensor for a Camshaft position sensor. Too many sensors for me :doh:

I am guessing this is what you were looking for

(8) 047907601
speed sensor / camshaft
/ ARV,AQV,ATY, AME,AQW,ATZ, AZE,AZF

It seems it is only common to the 1.4 (and 1.0 based on the 1.4 sold on the continent).

http://cgi.ebay.co.u...p-/290467231943

#10 sepulchrave

sepulchrave

    Yet another idiot who can drive a car...

  • Members
  • PipPipPipPipPip
  • 2,141 posts

Posted 26 June 2011 - 11:53

hi guys,

I am having real problems finding a second-hand CPS for the 8v.

Thanks Phil


Please don't use second-hand sensors, it's pure insanity, they're cheap enough new.