Jump to content


Photo
- - - - -

Fabia EPC Light


This topic has been archived. This means that you cannot reply to this topic.
26 replies to this topic

#1 Brindle

Brindle

    Briskodian

  • Members
  • Pip
  • 6 posts

Posted 31 January 2006 - 11:21

Car is Fabia 1400cc 100HP. Last May the EPC light came on occasionally when starting from cold. This didn't happen if you let the car idle for a couple of minutes. Dealer looked at code and told me it was the inlet pressure in manifold but advised me to leave it as it could be the throttle body and they didn't want to change one only to find it was the other.

By November, the light would come on as soon as the car was started. The revs dip briefly, the light comes on and then everything is O.K. Garage still say leave it. Car runs perfectly apart from this, returns 40-45 mpg on most runs and even passed it's MOT with the light on!

Question is does anyone got any ideas apart from above as I am concerned that with the Engine Management Light on I might miss another fault. Can this idicator be disabled?

Any help for a new member would be greatly appreciated.

#2 neilwilliams

neilwilliams

    Techie Teacher

  • Members
  • PipPipPipPip
  • 962 posts

Posted 31 January 2006 - 11:46

From the dealer comment it sounds like the car is out of warranty - is that right?

The engine and EPC lights come on for a range on things. It might be worth trying to get the fault code out of the dealer as some poeple on here will be able to help with the code. Alternatively contacting Skoda Customer Services might be a good idea.

#3 Brindle

Brindle

    Briskodian

  • Members
  • Pip
  • 6 posts

Posted 31 January 2006 - 14:11

Thanks for prompt reply.

You are right car is Feb 2000 owned since new. Garage didn't tell me the code but printout they did supply only says 'Intake Manifold pressure sensor'. They originally quoted £213.28 to replace but later said that they had done this on another car which did not cure problem but replacing throttle body did so they would not proceed until they could be sure which it was.

Will go in at weekend to get actual code.

#4 Pete

Pete

    Briskodian

  • Members
  • PipPipPip
  • 234 posts

Posted 01 February 2006 - 22:46

I had this on my 2000 1.416v 100hp unit. Was the pressure sensor thing. It was actually the last bit of work I had done under warranty. They also thought it could be the throttle body and had it back for a whole day to figure out exactly which it was.

#5 timmons

timmons

    Briskodian

  • Members
  • Pip
  • 6 posts

Posted 05 February 2006 - 13:50

Mine is now doing exactly the same thing. Its a 2000 1.4 100BHP . Sometimes EPC light is on, sometimes engine light, sometimes both, sometimes neither its very random and was wondering how easy it is to just go to a dealer and ask them to reset it or turn it off?!

#6 Brindle

Brindle

    Briskodian

  • Members
  • Pip
  • 6 posts

Posted 07 February 2006 - 15:01

Resetting it only works until the next time it happens, usually as soon as you pick it up from the garage!! Garage seem reluctant to disable sensor for some reason. I've decided to live with it although a friend tells me that there is a decent VW garage in Crowborough that helped with a problem he had with sensor lights on his Skoda. May give them a try.

#7 chajxf

chajxf

    Briskodian

  • Members
  • Pip
  • 7 posts

Posted 15 February 2007 - 13:40

I've got this problem too, also on a 2000 1.4 100bhp. Started about 2 weeks ago when both EPC and Engine light came on while driving. Pulled over to check manual and when I restarted car they'd disappeared. Couple of days later Engine light started coming on intermittently before disappearing. Now EPC light has come on and shows no sign of going this time around.
Tempted to wait till Service/MOT to get this sorted, as it sounds like a pretty common problem. Fingers crossed car won't die before then.

#8 Hastings David

Hastings David

    Briskodian

  • Members
  • Pip
  • 10 posts

Posted 15 February 2007 - 19:16

Hello chajxf.

Earlier this week, i had the same problem. Worth a look at the thread (link below).

http://www.briskoda..../?highlight=epc

#9 bizzarre_iou

bizzarre_iou

    Briskodian

  • Members
  • Pip
  • 3 posts

Posted 08 March 2007 - 15:11

similar problem, but i have de engine light also on an strange the asr light wich i can't turn of :confused: , i had it cecked and it turn out to be the Intake Manifold pressure sensor, i will have it changed next week and get back to you

#10 Siamak

Siamak

    Briskodian

  • Members
  • Pip
  • 1 posts

Posted 01 May 2007 - 08:23

I have the same problem on my fabia 2001 1.4 The light came on about 2 years ago. Since than I have spent a small fortune to find out what the problem is without success. First, the local garage thought it was a simple electrical fault (something shorting) He reset something and EPC light went off - for about 1/4 mile - Afte a year of persevering, I took it to Skoda dealer. Since then, they have clanged temprature sensor, brake light switch and a few other things, but the light is still on. I think they have run out of ideas and told me this can be either no fault but electrical malfunction or a serious engin fault - not very helpful eh? Anyhow, I think I may sell the car and after 10 years of being a skoda owner, move to another more reliable brand. Anyone knows anything about Toyota Priva?

#11 Ifezs

Ifezs

    Briskodian

  • Members
  • Pip
  • 2 posts

Posted 21 September 2007 - 20:51

Hi All,

I have a question about the EPC light.

I have a Skoda Fabia 2002 1.4 car

The EPC lightcome to visible today, and my break's light not working.

Do you have any idea what could be the problem?

Thanks

#12 Fabia_TDI

Fabia_TDI

    Briskodian

  • Members
  • PipPipPip
  • 107 posts

Posted 21 September 2007 - 22:45

If you are having problems with warning lights coming on it might be worth getting a fault code reader (I got one on eBay a month ago for about £20). That way you will always know if you have a fault code and what it is. The diagnostic port is behind the can holder in front of the driver on the right - I'd never have found it just by looking.

Here's one, actually

U281 CAN VW/AUDI Auto Scanner VAG Code Reader - eBay Diagnostic Tools Equipment, Garage Equipment Tools, Cars, Parts Vehicles (end time 24-Sep-07 16:27:13 BST)

#13 Ifezs

Ifezs

    Briskodian

  • Members
  • Pip
  • 2 posts

Posted 22 September 2007 - 07:46

Thanks,

Do you have any idea, why my break's light not viewable if I use my break?

#14 Fabia_TDI

Fabia_TDI

    Briskodian

  • Members
  • PipPipPip
  • 107 posts

Posted 22 September 2007 - 08:51

Check the bulbs and the fuses if you haven't already. If that's not the problem do a search on this forum for 'Brake light' - there's a lot of info about EPC warning lights and brake lights.

#15 rum4mo

rum4mo

    Briskodian

  • Members
  • PipPipPipPipPip
  • 2,266 posts

Posted 22 September 2007 - 09:10

If none of your brake lights come on when the brake pedal is pressed down fully, I'd just change the brake light switch as they are cheap and are known to fail regularly - take care when fitting the new switch as they are quite easily damaged if you are rough (clueless) with them. Good luck!

#16 GeordieJohn

GeordieJohn

    Briskodian

  • Members
  • PipPip
  • 91 posts

Posted 23 September 2007 - 13:18

Ive got management light on but that will be getting sorted some time soon through garage where i got car from, i sum times get epc light on but car runs fine, mayb time for it 2 goto a garage and get it hooked upto the computer, my management light comes up coz of a EGR value, changed it and still the light on, they reset system and still on, so if they find another problem they aint paying for the repairs coz its out of warrenty, but i noticed and got car booked in well in the warrenty time, so all will get ahold of fair trade :D. Anyways on saturday the 22nd i been drivin about and pulled ova to go to shop, came out got back in car started her up and power steering light was on lol, and the steerin was stiff, turned her off and put her back on and she was fine, :S wierd, also i get other lights flashin all at once brake fluid level (handbrake), ABS, Traction control system and ofcourse the management light wats always on for now. Hand brake isnt slightly on either, could this just be a ghost or someting serious? only way of knowin is going to skoda :D any idea as to why these lights are on thanks john, w reg skoda fabia 100bhp

#17 vicount

vicount

    Briskodian

  • Members
  • Pip
  • 31 posts

Posted 10 April 2009 - 15:10

just had the same problem with epc warning light, it just came on today and now the missus is barking again about the car, oh well it looks like another trip to the dealers!

#18 mlapicki

mlapicki

    Briskodian

  • Members
  • Pip
  • 21 posts

Posted 10 April 2009 - 21:44

Hi, I'm about 300 miles from home tonight. About 200 miles into the journey both the EPC and engine management light came on, then after stopping it got joined by a light which looks like a triangle with a counter-clockwise arrow around it. Does anyone know what this is. i don't have the manual with me. The car is trying to stall ever time it idles - so I had to keep the revs up myself (no fun in bank holiday traffic)

The MAP sensor was replaced yesterday following a spate of the engine management lights coming on.

Any help very much appreciated. Cheers. The car is a 54 plate 1.4 100hp

#19 m5rcc

m5rcc

    Briskodian

  • Members
  • Pip
  • 4 posts

Posted 15 June 2009 - 19:52

Hi, I'm about 300 miles from home tonight. About 200 miles into the journey both the EPC and engine management light came on, then after stopping it got joined by a light which looks like a triangle with a counter-clockwise arrow around it. Does anyone know what this is. i don't have the manual with me. The car is trying to stall ever time it idles - so I had to keep the revs up myself (no fun in bank holiday traffic)

The MAP sensor was replaced yesterday following a spate of the engine management lights coming on.

Any help very much appreciated. Cheers. The car is a 54 plate 1.4 100hp


I too have just got the same fault as mlapcki. Y-reg 100bhp 1.4 Comfort 16v with 34k miles. Emissions warning light has been coming on randomly over the last year with no real issues with performance except for self-revving on starting or starting with just 500rpm and almost choking before going to normal idle.

Tonight whilst driving emissions light, EPC, "triangle with counter clockwise circle. This appears to be a common problem and with the car worth 2k I dont want to spend best part of a quarter of its monetary value on trying to diagnose and repair. Can anyone shed any light?

#20 m5rcc

m5rcc

    Briskodian

  • Members
  • Pip
  • 4 posts

Posted 15 June 2009 - 19:54

Oh, also the brakes are super stiff and there's a hissing sound as if there's a hydraulic leak....!?

#21 cjb

cjb

    Briskodian

  • FREEDOM
  • PipPipPipPipPip
  • 4,418 posts

Posted 15 June 2009 - 19:57

I'll repeat what I always say: The ONLY answer to 'why is my EPC light on' is to connect the car to a scanner, preferably VAG-COM. Anything else is just guesswork.

#22 m5rcc

m5rcc

    Briskodian

  • Members
  • Pip
  • 4 posts

Posted 15 June 2009 - 20:50

Yes Sir! As you are a Briskodian, could you (or any other person) recommend a garage (in London) to carry out such work? I do not trust my local rip-off Skoda dealer.

#23 cjb

cjb

    Briskodian

  • FREEDOM
  • PipPipPipPipPip
  • 4,418 posts

Posted 15 June 2009 - 21:19

Oh, also the brakes are super stiff and there's a hissing sound as if there's a hydraulic leak....!?


You have a leaking hose, probably the one to the brake servo, that is leaking air into the inlet manifold.

#24 fordfan

fordfan

    .

  • Super Moderators
  • 5,302 posts

Posted 16 June 2009 - 06:30

We had one in last week showing an inlet pressure fault. That had a leaking brake servo hose.

#25 cjb

cjb

    Briskodian

  • FREEDOM
  • PipPipPipPipPip
  • 4,418 posts

Posted 16 June 2009 - 07:32

We had one in last week showing an inlet pressure fault. That had a leaking brake servo hose.

Lupos with a similar engine had a recall for this, and the bills that came with ours show a replacement.

#26 cjb

cjb

    Briskodian

  • FREEDOM
  • PipPipPipPipPip
  • 4,418 posts

Posted 16 June 2009 - 07:35

Yes Sir! As you are a Briskodian, could you (or any other person) recommend a garage (in London) to carry out such work? I do not trust my local rip-off Skoda dealer.

:)

Have a look here. Follow the link to the VAG-COM forum and find a local member. Mind you, with the other info you've given, there's a fair bet it's the brake servo hose, but the scan is a good idea anyway.

#27 m5rcc

m5rcc

    Briskodian

  • Members
  • Pip
  • 4 posts

Posted 16 June 2009 - 20:56

cjb was spot on: called the RAC and they found the issue within a minute: a leaking brake servo hose